BizTalk 2009 64 bits Adapters – WCF SAP Adapter – Troubleshooting Installation Issues – Missing sapBinding

Posted: November 27, 2009 in BizTalk
Tags: , ,

I recently have my second bad experience in installing/configuring adapters in 64 bits platform😦.

I installed, with success, the 64bits version of the BizTalk Adapter Pack 2.0, that contain:

  • Microsoft BizTalk Adapter for SQL Server. The Microsoft BizTalk Adapter for SQL Server exposes the SQL Server database as a WCF service. Adapter clients can perform operations on the SQL Server database artifacts such as tables, views, and procedures by exchanging SOAP messages with the adapter Supported SQL Server versions are SQL Server 2000, SQL Server 2005 and SQL Server 2008 The SQL adapter uses ADO.NET to communicate with the SQL Server database. The minimum requirement is .NET 3.5 SP1
  • Microsoft BizTalk Adapter 3.0 for Oracle Database. This Oracle database adapter enables adapter clients to read and write to and Oracle database-
  • Microsoft BizTalk Adapter for Oracle E-Business Suite. Using this adapter clients can perform operations on the the Oracle E-Business Suite artifacts (PL/SQL APIs, interface tables/views, concurrent programs, and request sets) and the underlying Oracle database artifacts (such as tables, functions, and procedures) by exchanging SOAP messages with the adapter.
  • Microsoft BizTalk Adapter 3.0 for mySAP Business Suite. This adapter enables clients to exchange Intermediate Document (IDOC), BAPI, and Remote Function Call (RFC) messages with the SAP system.
  • Microsoft BizTalk Adapter 3.0 for Siebel eBusiness Applications – This adapter enables clients to invoke Business Services and operations on Business Components in a Siebel eBusiness Application.

Problem:

Like I saw before, I installed, with success, the 64bits version of the BizTalk Adapter Pack 2.0, but when I tried to create a new SAP send port in BizTalk Administration Console:

  • In the received location:
    • Use the Custom WCF Adapter
    • Clicked on the “Binding” tab and select sapBinding

I cannot see sapBinding registered in the list of the “Binding” tab.

So why I cannot found sapBinding?

Cause:

The SAP adapter is a WCF custom binding, which is registered under System.ServiceModel in the machine.config file.

A 64-bit platform has two machine.config files, one used by the 32-bit applications and the other used by the 64-bit applications. So, when you install the 64-bit version of the BizTalk Adapter Pack, the setup wizard registers the bindings in the 64-bit version of the machine.config file.

However, Visual Studio runs as a 32-bit process and hence when you launch the Consume Adapter Service Add-in from Visual Studio, the plug-in checks for the bindings in the 32-bit version of the machine.config file and fails giving an error.

Like Visual Studio, BizTalk Admin Console runs as a 32 bit process as well which explains why the Adapter is not visible inside the console, it checks for the bindings in the 32-bit version of the machine.config.

Resolution:

Install both the 32-bit and 64-bit versions of the BizTalk Adapter Pack on a 64-bit WCF LOB Adapter SDK installation.

NOTE: You must only have a 64-bit WCF LOB Adapter SDK installation. Side-by-side installation of 32-bit and 64-bit WCF LOB Adapter SDK on a single computer is not supported.

This problem and resolution applies to the SQL Adapter as well.

Here some good related articles:

Tags: BizTalk | Adapters | Errors and Warnings, Causes and Solutions

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s