BizTalk 2010 – List of Known Issues and solutions with Setup and Configuration (Part 2)

Posted: September 6, 2011 in BizTalk
Tags: ,

The following are the known issues in BizTalk Server 2010:

Known Issues with Setup and Configuration

Issue: BizTalk Server installation may not launch automatically after a system restart

Cause: If .NET Framework 4 is not installed, the BizTalk Server setup installs .NET Framework 4 and then restarts the computer. After rebooting, the BizTalk Server setup may not start automatically.

Workaround:

  • In such cases, you must manually start the BizTalk Server installation.

Issue: On a BizTalk Server 2010 Standard/Developer/Branch edition, after you install and configure UDDI services, if you try to repair BizTalk Server 2010 by running the BizTalk Server 2010 setup from the product DVD, you may receive the following error:

Setup has detected that the Enterprise Edition of BizTalk Server 2010 was installed. Upgrading from the Enterprise Edition to the Standard Edition is not supported. Please uninstall the Enterprise Edition and then run the setup again.

Workaround:

  • Open the Control Panel, and then double-click Program and Features.
  • In the Program and Features dialog box, double-click the Microsoft BizTalk Server 2010 entry.
  • Click Repair.

Issue: Default settings have changed for ‘Maximum Worker Threads’ and ‘Maximum IO Threads’ from BizTalk Server 2009

In BizTalk Sever 2009, the default value for Maximum Worker Threads and Maximum IO Threads is the same as the .NET default values, but, in BizTalk Server 2010, the default value for the threads is lower than the values in the .NET default, this may result in performance degradation in certain scenarios. For example, the scenarios which have multiple running orchestrations.

Workaround:

  • You need to change/increase the values for Maximum Worker Threads and Maximum IO Threads at the Host instance level in BizTalk Server Settings Dashboard.

Issue: Reinstalling Visual Studio 2010 in a computer which already has Microsoft BizTalk Server 2010 configured causes an error

You may encounter an error "Error 5009. Registration of BAM performance counters failed. Return code -1." after you reinstall Visual Studio 2010 on a computer which already has BizTalk Server 2010 configured. This error occurs because the performance registry counters are damaged and needs to be rebuilt.

Workaround:

  • You need to rebuild the performance registry counters by using the command ‘lodctr /r’. For more information, see Lodctr.

Issue: Corrupted BizTalk Server 2010 installation may leave stale registry information which causes an error when you try to re-install BizTalk Server 2010

On trying to re-install BizTalk Server 2010, you may receive an error "Another version is already installed", but BizTalk Server 2010 is not installed in the computer nor is it a part of the list of installed programs. This error comes up if previous uninstallation/installation of BizTalk Server 2010 got corrupted and left stale registry information.

Workaround:

  • You need to run ‘msizap’ which cleans up the corrupt entries and allows you to install a clean version of BizTalk Server 2010. For more information, see msizap.

Issue: BizTalk Server Group Configuration does not add the read/write permissions to ‘\WINDOWS\TEMP’ folder

When configuring Groups in BizTalk Server Configuration wizard, the read/write permissions are not added to \WINDOWS\TEMP folder. This causes the following error when trying to deploy a schema:

"Attempt to deploy the schema for Microsoft.BizTalk.DefaultPipelines.PassThruReceive, Microsoft.BizTalk.DefaultPipelines, Version=3.0.1.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35 failed during call to .NET Framework method. This might be due to lack of permission to generate temporary Xml serializer assembly. Ensure that \WINDOWS\TEMP folder has the write permission for NETWORK SERVICE account set."

Workaround:

  • You need to manually add read/write permissions to \WINDOWS\TEMP folder.

Issue: SQL Server Browser Service is required when BizTalk Server is using a named instance of SQL Server

SQL Server Browser Service is not required in the following cases:

  • Microsoft BizTalk Server is using the default instance of SQL Server with TCP/IP running on port 1433.
  • User has full identification information (port number and named pipe) to connect to SQL Server.

For more information on SQL Server Browser Service, see http://go.microsoft.com/fwlink/?LinkID=199971.

Issue: BizTalk TDDS (Tracking Data Decode Service) fails to copy data from Message Box to DTA database on Turkish builds of Microsoft SQL Server

Workaround:

  • After BizTalk Server 2010 configuration, database collation of all BizTalk Server databases should be changed to Latin1_General_CS_AS, Latin1_General_Bin, or Latin1_General_Bin2. Run the following commands to change the database collation:

alter database <Database name> set single_user with rollback immediate
alter database <Database name> collate Latin1_General_BIN
alter database <Database name> set multi_user

Issue: Immediately after BizTalk Server 2010 installation, if you try to create a BizTalk Server project, or try to add certain BizTalk Server artifacts, some templates may not appear

You encounter this because the installation of Visual Studio templates is still running and is yet to complete.

Workaround:

  • You need to close all the instances of Visual Studio, and then wait till all the instances of devenv.exe process has completed. You can monitor running processes in the Task Manager. After completion of devenv.exe, if the templates still do not appear then you need to open Visual Studio command prompt (2010) as ‘Run as Administrator’, and then run the command devenv /InstallVSTemplates to ensure that all the templates are installed.

 

Issue: BizTalk Server 2010 Korean build installation may cause an error due to performance registry

You may get an error "Error 5009. Registration of BAM performance counters failed. Return code -1." during BizTalk Server 2010 Korean build installation because the performance registry counters are damaged and needs to be rebuilt.

Workaround:

  • You need to rebuild the performance registry counters by using the command ‘lodctr /r’. For more information, see Lodctr. After rebuilding performance registry, you should be able to reinstall BizTalk Server 2010.

Source: http://download.microsoft.com/download/0/F/F/0FFEF5D0-BE04-4D03-9125-75B8AD243E57/Readme.htm

Tags: BizTalk | Errors and Warnings, Causes and Solutions

Comments
  1. Brilliant post. The Developer Edition vs. Enterprise Edition was messing up the installation of the SharePoint adapter for me. The suggested fix (repair) corrected it and allowed that install to complete successfully.

  2. Bryan Meek says:

    Error 5009. Registration of BAM performance counters failed – I am using BTS 2013 and got this error after trying to repair/reinstall so I executed (as admin) the lodctr /R cmd and tried again but getting same result. Is it possible I need to reinstall VS 2012 then try a reinstall of BTS 2013 or do you know of some other workaround/step 2 if this first step does not fix the issue?

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s