Schema item missing from Visual Studio BizTalk Project items

Posted: September 10, 2012 in BizTalk
Tags: , , ,

This week I encountered a curious situation while I was developing a new BizTalk solution. After creating my new project, I tried to add a new schema to the solution, and to my astonishment, the item "Schema" had disappeared from the Visual Studio window "Add new item" in the "BizTalk Project items –> Schema Files" options, as you can see in the picture bellow:


Even if I choose the option "BizTalk Project items", that gives all BizTalk item, the Schema item was not there. By the way, this problem appeared from one day to another.


Well, unfortunately, I don’t know exactly why this problem occurred, but I believe that some dependence has become corrupted.


To fix this issue, or similar problems, you need to repair Visual Studio 2010.

To repair Visual Studio:

  • Click Start, click Control Panel, and then click Programs.
  • Click Programs and Features and then select the Visual Studio Edition you installed.
  • Click Uninstall/Change.
  • In the setup wizard, select Repair or Reinstall and then click Next.
  • Follow the remaining instructions in the installation wizard to finish.

After repairing Visual Studio, The "Schema" item was once again available:



Leave a Reply

Fill in your details below or click an icon to log in: Logo

You are commenting using your account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s